Erlang Versions Required and Supported by RabbitMQ

Minimum Required Version

The minimum version of Erlang required to run the RabbitMQ server 3.6.x is R16B03.

In general, use the latest available stable (GA) version of Erlang, or at least 18.0.

Installing Erlang/OTP on Debian and Ubuntu

Standard Debian and Ubuntu repositories provide Erlang/OTP but it is heavily sliced and diced into dozens of packages. In addition, unless the system has backport repositories enabled, the versions tend to be quite old. See Debian and Ubuntu installation guide for more information on the essential packages, dependencies, and alternative apt repositories.

Installing Erlang/OTP on CentOS, RHEL, Fedora

There are multiple RPM packages for Erlang/OTP, including a zero-dependency one from the RabbitMQ team. See CentOS, RHEL and Fedora installation guide for more information on the options.

Configuration- and Plugin-specific Erlang Version Requirements

Certain RabbitMQ configurations require more recent versions:

If you want to:Minimum versionNotes
build / run RabbitMQ server and most plugins R16B03
use TLS reliably 17.0 Covers most common signature algorithms and can honor server ciphers order. 19.2 or later version are recommended.
use rabbitmq_delayed_message_exchange 18.0

Erlang Versions in Clusters

RabbitMQ requires that the same major and minor version of Erlang is used across all cluster nodes (e.g. 19.2.x). RabbitMQ will check for protocol versions of Erlang and its distributed libraries when a node joins a cluster, refusing to cluster if there's a potentially incompatible combination detected.

It is highly recommended that all nodes use exactly the same version of Erlang.

Building from Source

If a sufficiently recent Erlang package is not available for your system then you will need to build Erlang from source. This requires a build environment that satisfies the Erlang build dependencies, such as OpenSSL.

kerl makes building Erlang/OTP releases from source, including specific tags from GitHub, a much more pleasant experience.

Older Erlang Versions

Last Version to Support R13B03

If you absolutely must use an older version of Erlang, RabbitMQ 3.5.8 is the newest version compatible with R13B03.